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Overview 
Dreamweaver is a software application for creating web pages.  It is known as a WYSIWYG editor because it allows you to 
design your pages visually without having to write HTML code.  The following tutorial walks you through development of 
a basic page.  It covers file management, formatting text, inserting images, making links, and creating tables.  It concludes 
with a short section on how to upload you page to the NMSU server so that it can be viewed on the web. 
 

Starting a New Page 
Step 1- Starting a new web page 
Begin by opening the application Dreamweaver.  
 
Step 2- Saving your file 
Save your file by going to File>Save As… 
The way you name and organize your files is important.  Here are the things you need to keep in mind: 

 Names cannot have spaces or non-alphanumeric characters.  
 All files used in your web site must be placed in the same folder. This includes any images you might use.  
 It is best to use short names and all lowercase letters because whatever you name the file is what the address (the 

URL) for getting to that page will be. 
 If you are creating a web site, name your main/home page “index.html” to further simplify the address users will 

have to type in 
 All web pages end in the extensions .htm or .html- You can use either, but stay consistent throughout your site. 

Dreamweaver should automatically include the extension when you save your pages. 
 
Step 3- Creating and formatting text within a document 
Start creating textual content by typing in the blank space of your document or by cutting and pasting text from another 
program (note that most prior formatting will be lost when you cut and paste Word documents).  Highlighting your text will 
allow you to make some basic formatting decisions by using the Properties palette shown here (if this palette isn’t visible, 
go to Windows>Properties): 

 
 
You can align page contents to the right, center or left using these buttons: 

 
 
You can create bulleted (unordered) or number (ordered) lists, as well as block indentations using these buttons: 

 
 
Font Style 
As you will quickly find out, your formatting choices are somewhat limited.  You can’t, for example, use the tab key or the 
space bar as you might in Microsoft Word to help align text. You can bold, italicize or change the size, color, or font, but 
that’s about it. You also have a limited number of fonts available.  These limitations are due to the structure of HTML (the 
code from which pages are built), not the Dreamweaver application. HTML was written so that every web page would look 
nearly the same on every computer and in every operating system.  Therefore, when you select a font, your choices are 
limited to those that are installed on every computer (e.g. Arial, Helvetica, Verdana, Geneva, Times, Courier, Trebuchet).  
You can use other fonts, but if a user’s computer doesn’t have that font, your text will default into something else that may 
not fit with your design intentions.  
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Most changes to font style using HTML and CSS take place through the “Page Properties” palette which can be accessed 
through going to Modify>Page Properties and clicking on the appropriate “Appearance” category on the left side. A 
screenshot of this palette is below. 
 

 
 
Font Size 
In the newer versions of Dreamweaver (MX 2004 through CS4), font size is measured by points just as it is in Word. You 
can also use a size relative system with measurements from “xx-small” to “larger”. 
 
Font/Text Color 
You can select a font color by clicking on the small box labeled “Text color”: 

 
 
The color picker menu that pops-up will allow you to pick one of 256 web-safe colors that should look nearly the same on 
all computers. If you know the hexidecimal color your would like to use, you can type this directly into the text color box. 
You can also click on the globe icon (system color) at the top right to get a color wheel for a broader selection, as well as 
the eyedropper tool to sample colors from images to match text.  
 
Step 4- Changing your page’s background color and link colors 
Changing the page background or link colors is accomplished on the Page Properties palette. You can also change the 
default white background, the default active and visited link colors, and the underline style of links. 
 
Step 5- Creating links 
There are two kinds of links used in web pages: absolute and relative. Absolute links go to web pages outside of your site 
and use the full URL (e.g. http://www.google.com). Relative links refer to pages within your own site and their location in 
your files is relative to the page from which you are linking. For these pages, you only need to include the name of the file 
with its file extension (.html), rather than the full address (e.g. “syllabus.html”). 
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To create either kind of link, first type out the text you want to be clickable and then highlight it with the cursor as below: 

 
 
Next, in the Properties Palette “Link” box, type in the name of the file you want to link it to or the full web address for a 
page outside your site.  You can also click on the little folder icon next to the “Link” box to select the page you want to link 
to within your own files. This second method can help to eliminate typos and thus, broken links. 
 
 
Step 6- Creating an email link 
Making an email link is similar to making absolute and relative links.  Begin by highlighting the text you want to be 
clickable.  Next, go to Insert>Email Link.  This will bring up a pop-up box as shown below. The “Text” box should contain 
the text you want to be clickable.  The “E-mail” box should contain the email address to which you want to link. 

 
 
Step 7- Inserting images 
There are a few things to keep in mind when considering including images in your web page. 

 Keep the size (dimensions) of your image relatively small. The bigger they are, the longer they take to download. 
Images should be relatively small in relation to the overall screen unless it’s critical to the message of your page. 

 Keep the resolution of images (the number of pixels per inch) to 72. Higher resolutions can’t be properly seen on 
screen and only make your files larger. 

 There are only three kinds of images that can be displayed by web browsers: .gif (used for simple illustrations with 
large areas of flat color), .jpg (used for photographs which include subtle variations in color), and .png (a vector-
based) format for displaying images that allows for resizing without distortion). 

 Store all images in the same file folder as your web page. Images are referenced and placed in the page by the web 
browser, so it needs to be able to locate the files. 

 Maintain the same rules for naming graphics as you do for web pages (no spaces, short names, no non-
alphanumeric characters). 

 When you insert an image you will be prompted to provide an “Alt tag”. Doing so allows visually-impaired users 
to use screen reading technologies to communicate the visual content of an image. 
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To insert an image, place your 
cursor in the space on your page 
where you want to put it and 
then go to Insert>Image.  This 
will bring up the “Select Image 
Source” pop-up window as 
shown to the left.  Browse and 
locate your image file by 
clicking on the file name.  Click 
“Select” at the bottom of the 
window. Again, be sure that the 
image file is saved to the same 
folder as your html files. 
 
If you want your text to wrap 
around the image, click once on 
the image on your web page to 
select it (you’ll know you’ve 
done this if a thin black box 
appears around your image). 
You will also notice that when 
the image is selected, the 
Properties palette changes to 
provide information and editing 
options for the image as shown 
below: 
 
 
 
 

 
 
By selecting left or right from the “Align” drop-down menu, the text will automatically flow around the image rather than 
simply aligning with the bottom of the image as the default setting does. 

 
 
 
Step 8- Creating tables to organize 
information 
Since you cannot use tabs or extra 
spaces to arrange material in a web 
page, using tables provides you with a 
greater diversity of page layout options. 
You can choose to leave the borders of a 
table “on” and visible for content (such 
as a schedule) where it is important to 
align information in various rows and 
columns.  You can also turn “off” 
borders as a way of arranging 
information without users necessarily 
seeing how you’ve done it. A table with 
the borders turned on is shown below. 
Note: tables have largely been replace 
with CSS, but can still provide some useful formatting options. 
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To create a table, go to Insert>Table,  This will open the pop-up window shown above.  In this example, I have created a 3 
row (horizontal), 3 column (vertical) table with a width of 750 pixels (you can also set the width to be a percentage of the 
user’s browser window rather than a pre-set width).  The “Border Thickness is set to “1”, so it will be visible to users. “Cell 
padding” and “Cell spacing” boxes allow you to create extra room between cells and extra distance between the interior 
edge of a cell and its contents.  In the example shown below, I have given the top row a different background color to help 
highlight this as the headings for each of the columns.  This can be done by clicking in the cells you want to change (hold 
down shift while doing this to select multiple cells), then using the color picker in the “Bg” box of the Properties palette as 
shown in the second graphic below. 

 
 
The default setting for tables is to make each cell the same width, but you can adjust these by placing the cursor over the 
edges of cells and dragging the lines.  Another default setting for tables is to have their content be placed in the middle of 
the cells.  To have content begin at the top of cells, click in the cells and select “Vert>Top” from the Properties palette. 

 
 
 
Bonus Step- Including PDF and Word documents on your web page 
Because you may want to make scanned readings, assignment sheets or other materials available to your users via the web, 
you can include links to PDF and Word documents (as well as just about any other format).  Rather than displaying in the 
browser, though, clicking on these links will download the file to the user’s computer.  Just as with regular links, you want 
to highlight the text that you want to be clickable. Next, click on the folder icon next to the Link box in the Properties 
palette and locate the file you want to link. (NOTE: it is critical that you place a copy of the file you want to link in the 
same folder as your web page file). 
 
 
Step 9- Testing your page in a web browser 
In order to see what any additions or changes you have made will look like when the page displays in a web browser (i.e. 
Internet Explorer, Firefox, Safari), you will need first to save your page. Next, go to File>Preview in Browser>Safari (or 
whatever browser you prefer).  If you’ve made links within your page, these should now be clickable. 
 
 
Step 10- Uploading your pages to the web 
Once you have completed your page(s), you can place your work on a server so that it can be accessed by anyone on the 
web.  You have 50MB of free space on the NMSU web server. Dreamweaver has a built-in FTP (file transfer protocol) 
component that makes this process quick and easy. 
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To begin the process of uploading your files, go to Site>Manage Sites and click “New” on the pop-up window. Next, in the 
Site Definition window that will pop-up, give your site a name.  This is just for you, so you can name it anything you want.  
In the Local Root Folder slot, click on the folder to the right and browse to find the folder where all of your web files are 
stored. You can ignore the other boxes. 

 
 
 
 
Next, click on “Remote Info” under the Category list on the left.  Under the “Access” drop-down menu, select “FTP”.  
Every faculty member and student has 50MB of free web space on the NMSU server (and can generally get additional 
space if necessary by contacting ICT). To place your files here, type “web.nmsu.edu” in the FTP host box. In the Host 
directory box, type public_html. Next to Login and Password, type the login and password you use to access your campus 
email, myNMSU, and/or Blackboard.  When done, click OK. 

 
 
Once you have completed this, a two-columned “Files” window will pop-up. In the right column are the files 
you have been working on and that are saved locally on your computer. To show what is in your files on the 
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server and to begin the transfer process, click on the small plug icon at the top of this window on the left.  This connects 
you to the Remote Server and displays any files you may already have there. If you do not already have a folder on the 
Remote Site (server) called public_html, create an empty folder with that title and place it in your local file folder. Follow 
the steps below to move this to the server and then place your html and image files in it. 
 
Finally, click on the small arrow next to the folder called “public_html” in the lefthand column. (If you don’t have this 
folder, create an empty one within your local folder.  Next, click on the new folder in the right column and drag it to the left 
column). To transfer your files (both html and image, as well as any PDF or Word documents you want to link), click on 
them one at a time in the right column and drag them to the left column’s public_html folder. Release the mouse when the 
public_html folder is hightlighted. 
 

 
 
 
Step 11- View your finished work online 
If you saved your home page as index.html (or.htm), and placed your files on the NMSU server, the web address for your 
page will be http://web.nmsu.edu/~username where “username” is what you use to login to your email. (Note that the mark 
before “username” is a tilda, not a dash). 
 
 
 
 
 
 


